Deleting last row(s) in the last table [was: Ver. 3.05]

Technical support discussions and Bug Reports – You find em, we squash em

Deleting last row(s) in the last table [was: Ver. 3.05]

Postposted Vicparker » April 25th, 2013, 6:11 pm

Selecting and deleting rows in tables is unpredictable especially when selecting multiple rows.
Is this a known problem, and is it still too early to be reporting bugs in Ver . 3.05 build 750 ?

I don't remember anything wrong here in ver. 3.04 build 725.
Victor
Vicparker
 
Messages: 82
Member since:: January 14th, 2011, 7:37 pm
City/Country: USA/AL

Re: Ver. 3.05

Postposted vlad » April 27th, 2013, 8:07 am

Actually we didn't changed anything regarding table rows in 3.05, please give me more details how to reproduce the issue.
AllMyNotes Organizer usage example: store records on your domestic pets - vaccination schedule, collect articles about feeding, and recommendations from your vet
vlad
Site Admin
 
Messages: 912
Member since:: January 6th, 2011, 2:58 pm
City/Country: Earth -> Europe

Re: Ver. 3.05

Postposted Vicparker » April 27th, 2013, 6:20 pm

Hi Vlad,
While in blank note, Ctrl-T, Enter, "place cursor in first column, third row", "Ctrl-Shift End, Delete", once again "Ctrl-Shift End, Delete", the whole table disappears.
Vista Home Premium SP2. Intel Core2 Quad CPU Q6600 @ 2.4GHz 6.00 GB 64-Bit

Victor
Last edited by Vicparker on April 29th, 2013, 1:54 am, edited 1 time in total.
Vicparker
 
Messages: 82
Member since:: January 14th, 2011, 7:37 pm
City/Country: USA/AL

Re: Ver. 3.05

Postposted mx100 » April 29th, 2013, 12:25 am

I can confirm deleting whole table when it's not expected in v.2.70.

In some cases when trying to delete last row in the table by selecting it and clicking Del key the whole table disappears. The same happens when you delete last 2 rows, last 3 rows, etc. but it doesn't happen when you delete rows in the middle (only when it includes last row in a table).

I found one pattern when it happens - it does when there is no empty line after the table because it was previously deleted with some last rows which is another issue because deleting the line wasn't expected too.

I wanted to attach an example but ddb extention not allowed here :(
mx100
 
Messages: 18
Member since:: March 25th, 2013, 10:01 pm

Re: Ver. 3.05

Postposted Vicparker » April 29th, 2013, 2:05 am

After you delete the selected rows, and left click anywhere on the blank note the table pops back up.
Vicparker
 
Messages: 82
Member since:: January 14th, 2011, 7:37 pm
City/Country: USA/AL

Re: Ver. 3.05

Postposted mx100 » April 29th, 2013, 2:43 am

You're right... i always typed Ctrl+Z instantly when it happened because i didn't want to loose what i was creating. So in my case it misses to redraw table only.
mx100
 
Messages: 18
Member since:: March 25th, 2013, 10:01 pm

Re: Ver. 3.05

Postposted Vicparker » April 29th, 2013, 4:20 am

Ctrl-Shift Home does not work as expected either, in a table.
Vicparker
 
Messages: 82
Member since:: January 14th, 2011, 7:37 pm
City/Country: USA/AL

Re: Ver. 3.05

Postposted vlad » May 8th, 2013, 3:46 pm

Vicparker wrote:While in blank note, Ctrl-T, Enter, "place cursor in first column, third row", "Ctrl-Shift End, Delete", once again "Ctrl-Shift End, Delete", the whole table disappears.


Thank you for detailed steps, I've reproduced and fixed the issue, the fix will be included in version 2.71 and 3.06 (beta).

Vicparker wrote:After you delete the selected rows, and left click anywhere on the blank note the table pops back up.


Right, the table wasn't actually deleted, just cursor position was out of valid range, which lead to incorrect table painting, which could look like table is deleted/lost, while was enough to click anywhere on the text are, and voila, here it's, back and alive :)
AllMyNotes Organizer usage example: store records on your domestic pets - vaccination schedule, collect articles about feeding, and recommendations from your vet
vlad
Site Admin
 
Messages: 912
Member since:: January 6th, 2011, 2:58 pm
City/Country: Earth -> Europe

Re: Deleting last row(s) in the last table [was: Ver. 3.05]

Postposted Vicparker » May 8th, 2013, 5:46 pm

Thanks Vlad for the good work.
victor
Vicparker
 
Messages: 82
Member since:: January 14th, 2011, 7:37 pm
City/Country: USA/AL

Re: Deleting last row(s) in the last table [was: Ver. 3.05]

Postposted mx100 » May 10th, 2013, 4:42 am

Thx for the fix!
mx100
 
Messages: 18
Member since:: March 25th, 2013, 10:01 pm


Return to Troubleshooting

cron